Problems with the current design:
old notes:
ApplianceGroup.disaggregated_leaves() need to think of a better name. distinct leaves? Leaf meters? Separable appliances? Separate appliances? Submetered appliances? Returns list of ApplianceGroups, one per meter or dual supply appliance. Or maybe that's over complex. Basically just need downstream meters except dual supply appliances where we need the two meters together. Maybe I need a PowerStrip class to aggregate multiple appliances under one meter? No, don't think I need a new class... All the information we need is encoded in the structures we have, we just need to make sure we process and package it up appropriately. Specifically, we must not try to train a disaggregation algo to learn appliances which we say are separate but are actually the same meter. And ApplianceGroup needs to only count each meter in the group once.
In [ ]: